Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Engine
#1
1931 RN Saloon, when driving at 30mph, oil pressure is only registering at 2. On warm start up she pressurises within a second or so and on cold start up instant pressure and fills the clock.
I am running on SAE30 and recently cleaned the sump gauze, I am a little concerned that the 2PSI drops to nothing when you stop at traffic lights to an idle. if you touch the accelerator oil pressure will increase between 2 and 4 depending on how high you rev. one other apparent point this car has had for years, when you switch off after a 5-6 mile drive and immediately engage the starting handle it is ever so tight to turn over for the first revolution, if you continue on past 1 revolution she is quite free as normal and never does it when cold or partially warm. The engine is not over heating nor is fan belt slipping and had a recent head off de-coke. I would appreciate if anyone could put my mind at ease on these matters?
Reply
#2
Your oil pressure sounds ideal. Relax and enjoy.
Reply
#3
(14-04-2018, 03:26 PM)Nick Turley Wrote: Your oil pressure sounds ideal. Relax and enjoy.

Thanks so much, my late father did always warn me that high oil pressure was more of a problem in an A7. I'm more used to Willis Keeps, Daimler Ferrets and M35 Reps. any idea about the tightness?
Reply
#4
(14-04-2018, 04:33 PM)AlfieM Wrote:
(14-04-2018, 03:26 PM)Nick Turley Wrote: Your oil pressure sounds ideal. Relax and enjoy.

Thanks so much, my late father did always warn me that high oil pressure was more of a problem in an A7. I'm more used to Willis Keeps, Daimler Ferrets and M35 Reps. any idea about the tightness?

To be honest I am not sure. 
You will understand it is a bit difficult without touching the car.
It does not sound serious to me, could be that the starting handle is not exactly central when hot.
Unless you have some fundamental concern over this I would be inclined to "let well alone"
You could involve yourself  in a lot of work for little advantage.
I presume it starts OK on the starter when hot ?
Reply
#5
Being messing with my special today and the starting handle is jamming now and again. It needs investigating but I suspect it is the spring which pushes out the handle which is trapped at the engine end between the shaft and the ali nose cone. By “engine end” I mean the ali casting has a cam shape which holds the starting handle horizontal,aided by the starting handle spring.
Reply
#6
(14-04-2018, 08:08 PM)Nick Turley Wrote:
(14-04-2018, 04:33 PM)AlfieM Wrote:
(14-04-2018, 03:26 PM)Nick Turley Wrote: Your oil pressure sounds ideal. Relax and enjoy.

Thanks so much, my late father did always warn me that high oil pressure was more of a problem in an A7. I'm more used to Willis Keeps, Daimler Ferrets and M35 Reps. any idea about the tightness?

Nick I will take your advice and leave well alone. cheers

To be honest I am not sure. 
You will understand it is a bit difficult without touching the car.
It does not sound serious to me, could be that the starting handle is not exactly central when hot.
Unless you have some fundamental concern over this I would be inclined to "let well alone"
You could involve yourself  in a lot of work for little advantage.
I presume it starts  OK on the starter when hot ?
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)